HomePage Forums Traveler Date format on checkout pages

Topic Resolution: Not Resolved

This topic contains 30 replies, has 2 voices, and was last updated by  actigner 3 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • #11938

    I have not been able to find where the date display format is controlled on the checkout pages, specifically for “Departure date:”. Changing the WordPress date display setting works for most situations but not all. I am attaching some examples. I also found a date format setting in the Traveler advanced settings but changing that did not seem to make any difference.

    Attachments:
    You must be logged in to view attached files.
    #11993

    Hello

    You can change the date format in Traveler Settings > Advance Options > Input date format.

    Thanks

    #12022

    Thanks Bryan but I had already configured that field to display the date format I wanted. As a test, I changed it around so that the year was first but that did not affect the “Departure date:” being displayed. Here’s my current setting in the attachment.

    Attachments:
    You must be logged in to view attached files.
    #12071

    Hello

    As your image setting, the year stay in the last place so it can not display at the first in departure date.

    Please check again.

    Thanks

    #12078

    Displaying the year first was only a test to see if anything changed in the area where the “Departure date:” is displayed. From what I can tell, the date formatting in the Theme Advanced Settings has no effect on that particular date display. Maybe it’s a WooCommerce setting.

    #12120

    Hello

    Currently, there is only place to change date format of theme.

    Thanks

    #14946

    Bryan,

    I still cannot resolve the issue with the date format displaying incorrectly in the checkout process. I want DD-MM-YYYY but I am getting MM-DD-YYY in the display for “Departure Date”. Everywhere it seems to be the correct DD-MM-YYYY format. I thought it might be a Woocommerce issue so I added a piece of code I found to functions.php that supposedly enabled control over the date format but that made no difference. I have set the date format correctly in the WP general settings and in Traveler so that is not the issue.

    I really need this resolved so any help you can give me would be appreciated.

    Alan Tigner

    Attachments:
    You must be logged in to view attached files.
    #14967

    Hello

    Woocommerce usign date format in Settings > General > Date Format.

    Please check it again because i can not access your admin dashboard.

    Thanks

    #14971

    I tested changing that setting two different ways and neither made a difference in what was displayed. I believe that your code has been added to the Woocommerce checkout pages as they appear different than the standard Woocommerce pages (I tested this) and contain info about the tour that is being booked. I’m attaching two more screen shots.

    I have also elevated you to administrator again if you want to look at the site.

    Attachments:
    You must be logged in to view attached files.
    #14976

    I believe that whatever is populating the data that is controlled by “st_booking_data” which is called my Woocommerce modules (cart.php, etc.) in the checkout process and may be the issue is. Just offering my suspicions.

    #14978

    Hello

    I checked again and see we fixed the date format in the code so it does not take the date format in theme setting to display.

    We will update it right away.

    Thanks

    #15036

    Bryan,

    Would it be possible to get the fix for this as soon as possible as that is the reason we have not launched the site? I am only in Vietnam a few more days and would like to get that resolved. If you want to update my installation directly before a fix is added to the template that would also work.

    Thanks,

    Alan Tigner

    #15067

    Hello

    I attached a zip file that content 2 files to fix this issue. You can unzip the file and copy the 2 files to wp-content\themes\traveler\st_templates\tours and replace by existing file to fix.

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #15085

    Bryan,

    That fixed the date on the cart page but not on the final order page or either email (office/customer). Hopefully it won’t be complicated. I’m attaching examples.

    Thanks again.

    Alan Tigner

    Attachments:
    You must be logged in to view attached files.
    #15089

    In addition to the other locations it is also not correct in the Woocommerce order information.

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 31 total)

The forum ‘Traveler’ is closed to new topics and replies.