HomePage Forums Traveler Member is Redirected to Checkout when Choosing a Free Package

Topic Resolution: Resolved

This topic contains 12 replies, has 4 voices, and was last updated by  Thao Le 2 years ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #12299

    Hi there,

    There is nothing to pay for a free package. However, the member is redirected to the checkout page. As it is not possible to pay “0”, the package is not activated for the services.

    See attached pictures.

    Please help. Thanks.

    You must be logged in to view attached files.


    If the membership package has price $0, theme automatic use Submit form method for payment. You can check and approve it from admin dashboard.



    Hi Bryan,

    I understand. But the problem here is for the Partner. It is totally confusing for him to see the checkout page for a free product. He doesn’t know what to do.
    I did the test, and I was very confused. Imagine a regular person…

    Is there a way to avoid that?


    Obs.: I have also noticed that packages are not ordered by price. It should be good if we can display them ordered by price from left to right, with the lowest price (or free) on the left, and the highest price on the right.



    When partner buy something, even free package with $0, you should checkout for that to complete steps.

    Also i will transfer the order by package price to update it in next version.



    Hi Bryan,

    The Partner can’t complete the checkout in this case. That’s the problem.

    After filling all the fields and clicking Submit, he/she get an error message and remains on the checkout page (see pic 1 above). He/she doesn’t know what to do next.

    You can try it by yourself and you’ll see what happens.

    If possible, perhaps we can redirect the Partner to the dashboard after clicking the Submit button…




    I checked and see you have disabled submit form for payment so theme does not allow to pay with 0$.

    Please check again.



    Hi Bryan,

    Payment method by submitting a form will not be allowed on my site. That’s why this option has to be disabled.

    (Moreover, the Partner checkout page is not a simple form. You have to select payment options like Paypal or Stripe).

    I would much appreciate if you can find another solution for this issue.




    Unfortunately, no any payment gateway accept make the pay with $0 so we change to use our submit form.

    If you turn it off, there is no other option to make the free membership package for partner.

    Thank for your understanding.


    Hi Bryan,

    OK, I’ll find another solution for the free package. Thanks for helping.


    I have the same issue. Its confusing for the partner to have to chose a payment gateway if the price is 0. Wouldn’t it just be easier to have an IF statment somewhere that asks IF the cart is $0, then only show the Traveler Allow Oline Payment option? That way the user cant be confused and try to checkout using paypal/stripe/etc?

    This also fixes the issue of if a partner gives a coupon that brings the price to 0. The user would then still be able to checkout and not be confused.

    To expand on this, you should hae it show the Traveler Allow Online Payment option if the price is 0, and only show Stripe/paypal/etc if the price is greater than 0. Makes it less confusing and adds functionality.

    I imagine it would be an IF statement somewhere in class.payment_gateways.php


    Hello There,

    We saw that you had marked your ticket “Resolved”, hope you have done well with this.

    Please let us know if you need any further.



    This is still an issue for me – but I cant speak to the person who created the thread.


    Hello There,

    We saw you had marked this ticket as “resolved”, hope you can done well with this.

    Please be patient and wait for our response in your other ticket.


Viewing 13 posts - 1 through 13 (of 13 total)

The forum ‘Traveler’ is closed to new topics and replies.