HomePage Forums Traveler Trying to register a \"partner\" user not working

This topic contains 14 replies, has 3 voices, and was last updated by  Bryan 3 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #11968

    Trying to register a \”partner\” user not working.

    Step 1:
    – Clean cache
    – Open front
    – Account>>Sign Up>>opens register-user/
    – Select Partner User
    – add details
    – Accept TC’s
    – Click Register: (wouldn’t accept any previously used testing names/ email although they have been removed and purged!)
    – Success!.Registration successful! Please wait for administrator’s approval

    Step 2:
    – login to admin on clean cache
    – Yes I see the admin note (Have 1 new user partner need check for approved.Click Here!) but please refer to earlier post about issues with this not working.
    – YES it is in the users page in admin
    – NO it isn’t in the partner statistic/ list partner list (but please refer to earlier post about issues with this not working.)No Data
    – NO emails to user or admin received!
    – I am using the method (Admin must confirm partner) I will now turn this off and see result.

    Automatic approval
    Partner be automatic approval. SET to ON now:

    – Made registration no problem
    – Now log into admin
    – NO emails to user or admin received!
    – Yes the registration is in user page in admin as “Partner”
    – NO it isn’t in the partner statistic/ list partner list (but please refer to earlier post about issues with this not working.) No Data

    So the test concludes that the register partner not working with or without the function: (Admin must confirm partner)
    Issue with wp-admin/admin.php?page=st-users-list-partner-menu

    Please help with this thanks

    #11985

    Update Automatic approval yes received the email “Congraturation! Your account ready approved as Partner. You can upload content as service register”

    But in order for email to be received I used a friends email address not related to me and it worked.

    – now logging in as the pre approved partner user /my-account/:
    – how can we create tour etc?
    – now lets see if in the ADMIN for partner as it is pre approved and has sent the email stating this: NO it isnt in the list!

    – How do I get my dashboard to look like this too?: http://travelerdata.wpengine.com/page-user-setting/?sc=setting

    #12062

    Hello

    The problem is your multi site. It does not allow to register and the option of user role is gone.

    It does not display in Settings > General > New User Default Role section like normal wordpress.

    Please check again.

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #12403

    Ok thanks, so are you saying it cant work with a Multisite environment? OR rather if I change the settings via the Network settings to allow new users it will work?

    I can confirm that in the network settings as per this attachment “Registration is disabled” so I have now changed it to “User accounts may be registered” BUT as you can see in next attachment users were being created before I changed this setting!

    Attachments:
    You must be logged in to view attached files.
    #12406

    Ok so I have added a NEW partner and I received the email- Good

    As per before the partner is now listed in the users as a partner- YES

    Still same issue not listed in the “Partner statistic”/ “List Partner” section using the setting to allow registration withOUT approval!

    So changing the WP multisite network settings to allow New users hasn’t fixed this issue, please advise thanks.

    #12488

    Hello

    Not sure what happen with your multi site, the default user role of wordpress has gone.

    Our theme using that data to set user and partner role after they registered account and it can not work if the setting disappear.

    Thanks

    #12572

    Hi so did you see/ read this post before my last in this thread? 12403 REPLY
    – so you can see that the roles are working and being a multisite the super admin has controls on what you say is missing “the default user role of wordpress has gone.”

    – The issue here is that the partners are not being listed in the partner section although there are in the user section.

    #12611
    This reply has been marked as private.
    #12615
    This reply has been marked as private.
    #12616

    Yes I understand this as the issue so does this mean that your theme will not work on a multi site? Do you have a suggestion or I wil try to find a solution

    #12619

    Would this work: https://wordpress.org/plugins/new-blog-default-user-role/

    or if I…

    <?php
    function ds_new_user_meta($blog_id, $user_id) {
    add_user_to_blog(‘1’, $user_id, ‘subscriber’ );
    }
    add_action( ‘wpmu_new_blog’, ‘ds_new_user_meta’, 10, 2 );
    ?>

    blog_id could be edited

    #12650

    Quando o usuário vai até a pagina para se cadastrar e clica na opção de parceiro e após insere seus dados e clica em enviar funciona. Porém na página do administrador não está aparecendo a opção para aprovar novo usuário (já desabilitei opção para aprovação automática).

    Se eu vou em usuário e visualizo o usuário cadastrado aparece como a função padrão do word press. Porém eu quero que quando o usuário optar pela oção de parceiro no painel de administrado aparece como parceiro, e quando o usuário optar pela função de cliente ele seja cliente e não a função padrão do wordpress.

    #12691

    O sistema usa essas informações para identificar contas normais e parceiras.

    Se o seu sistema não tiver esses dados, as informações da conta e as funções relacionadas não funcionarão corretamente.

    Obrigado.

    #12736

    How do I check my system?

    #12766

    Hello

    We just support theme function here so you should contact your server admin to help you check better.

    Thanks

Viewing 15 posts - 1 through 15 (of 15 total)

The forum ‘Traveler’ is closed to new topics and replies.